Back to the index page  
  FAQ   Rechercher   Membres   Groupes   S’enregistrer   Profil   Se connecter pour vérifier ses messages privés   Connexion 
[Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132
Aller à la page: 1, 2  >
 
Poster un nouveau sujet   Répondre au sujet    Installer OS X sur PC Index du Forum :: Avant et Après l'installation :: Problèmes d'installation sur PC Intel
Sujet précédent :: Sujet suivant  
Auteur Message
Francis


Hors ligne

Inscrit le: 16 Nov 2008
Messages: 14

MessagePosté le: Lun 24 Nov 2008 - 08:39    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
Bonjour

J'ai déjà installé avec succès sur le même PC une Kaliway 10.5.2 qui tourne sans souci, que ce soit avec le kernel vanilla ou celui de Kabyl.

Pour résumer le matos :
Carte mère : Supermicro PDSBE
- Intel 82P965/G965 (vidéo intégrée désactivée)
- Audio HDA (Realtek ALC883)
- Chipset Intel 82801H ICH8 (USB, PCIExpress 16X, SATA AHCI x4)
- Ethernet 1Gb chipset 82573L

Proc : Core2duo E6320 (support SSE2/SSE3)

Ram : 4 Go Samsung

Carte graphique : NVIDIA 8500GT 256Mo fanless (Gigabyte)

Graveur DVD/DVD-RW Sata Optiarc (AD-L7191S)

J'ai décidé de faire une install boot-132 /original léopard à côté de la Kaliway histoire d'avoir un système le plus "vanilla" possible, pour les mises à jour, la stabilité, et l'amour de l'art. Smile

J'ai donc généré un iso contenant les kext adaptés à mon matos en googlisant pas mal à partir des forums insanely-mac.
Bref, à partir du CD de boot que j'ai gravé, l'install en mode texte (-x -v) se déroule correctement pour le chargement des kext, le disque et le graveur SATA sont reconnus et gérés en AHCI, la carte réseau est identifiée et l'autonégociation de la vitesse est ok, l'ACPI est reconnu, la GeForce 8500 GT est reconnue par Nvkush.
J'ai essayé pas mal de modifs sur mon iso de démarrage, mais a priori j'ai fait le tour de la question, les kext me paraissent ok.
En tout cas je n'ai rien vu pendant l'affichage sur la consol lors du boot qui indique un souci.

C'est au passage au mode graphique pour le début de l'install que ça se gate : le fond d'écran étoilé de léopard apparaît, la souris se transforme en la sinistre "spinning beachball" et ça reste planté là... Pas de suite, je suis obligé de rebooter.

Pour l'instant j'ai essayé avec une copie de mon DVD original, je vais essayer avec l'original *original* ce soir, je voulais valider la copie avant.

A part un problème de copie, qu'est-ce que ça pourrait être un plantage à ce stade ?

Si vous avez des suggestions...
_________________________________________________
--
Francis


Dernière édition par Francis le Sam 29 Nov 2008 - 20:02; édité 1 fois
Revenir en haut
Publicité






MessagePosté le: Lun 24 Nov 2008 - 08:39    Sujet du message: Publicité
PublicitéSupprimer les publicités ?
Revenir en haut
tete1995
Modérateur

Hors ligne

Inscrit le: 05 Mar 2008
Messages: 2 413
Localisation: Soissons
Masculin

MessagePosté le: Lun 24 Nov 2008 - 19:54    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
et bien, j'ai du mal a dire...
Alors bon si tu pouvais changer le appleACPIPlatform sur ton CD de boot, ce serait bien
_________________________________________________
Dell 1720 C2D T7250 2go 320Go 8600M GT
iPhone 3G blanc 16Go Jailbreaké
Mighty Mouse bluetooth
configuration : 100% working avec véritable mac os x installé
avec sorties vidéos fonctionnelles Wink
un petit click s'il vous plaît Smile
ma brute
Je ne réponds plus aux demandes d'aide par MP
Revenir en haut
Francis


Hors ligne

Inscrit le: 16 Nov 2008
Messages: 14

MessagePosté le: Lun 24 Nov 2008 - 20:47    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
tete1995 a écrit:
et bien, j'ai du mal a dire...
Alors bon si tu pouvais changer le appleACPIPlatform sur ton CD de boot, ce serait bien



Merci pour la suggestion, je vais faire l'essai et je dis quoi.
_________________________________________________
--
Francis
Revenir en haut
Francis


Hors ligne

Inscrit le: 16 Nov 2008
Messages: 14

MessagePosté le: Mar 25 Nov 2008 - 13:37    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
Donc : "quoi" Shocked

Plus sérieusement, après avoir changé le AppleACPIPlatform.kext pour un plus récent, ça ne change pas la situation.
Pour être plus précis, j'ai fait plusieurs essais en ne changeant à chaque fois qu'un kext, celui pour la carte graphique.

le contenu de mon iso, hors le ou les kext pour la gestion de la carte (Nvidia 8500GT 256M) :

ALCinject.kext
AppleACPIPlatform.kext
AppleAHCIPort.kext
AppleHDA.kext
ApplePS2Controller.kext
AppleSMBIOS.kext
Disabler.kext
IOAHCIFamily.kext
IOATAFamily.kext
IONetworkingFamily.kext
IntelCPUPMDisabler.kext
SMBIOSEnabler.kext
dsmos.kext

A priori tout ça, ça à l'air d'aller.

J'ai donc essayé avec cette config +

NVkush.kext = = plantage juste après avoir affiché le fond étoilé, avec le "spinning beachball", avant l'affichage de la moindre fenêtre

sans NVkush, sans rien ou avec

GeForce.kext
GeForce8xxxGLDriver.bundle
GeForceFXGLDriver.bundle
GeForceGA.plugin
GeForceVADriver.bundle
NVDANV50Hal.kext
NVDAResman.kext
NVinject.kext

= plantage en mode texte juste avant l'affichage du fond étoilé, avec l'erreur :
display: family specific matching failed

Bon, ça me fait dire que j'ai une <meeeeeep> avec le support de la carte graphique (enfin, au moins avec ça, peut-être avec d'autres trucs aussi, soyons optimiste Laughing
Après réflexion, je me dis que c'est un peu normal l'erreur avec les kext GeForce dans la mesure où je ne les avait pas modifié pour rajouter les deviceID pour la 8500GT... Embarassed
Donc j'ai modifié ça en suivant les conseils de cette page :

http://forum.insanelymac.com/index.php?showtopic=130652&st=0&p=9261…

Et j'ai modifié de même le ALCinject pour l'audio, histoire de...

Pour info, pour la NVidia 8500GT 256 Mo Fanless par Gygabyte, c'est 0x042110de  et pour l'audio HDA Intel de ma carte mère (alc883) c'est  0x15d98086.

Je teste ce soir et je raconterai si ça va mieux.

Si quelqu'un a une autre idée ?
_________________________________________________
--
Francis
Revenir en haut
tete1995
Modérateur

Hors ligne

Inscrit le: 05 Mar 2008
Messages: 2 413
Localisation: Soissons
Masculin

MessagePosté le: Mar 25 Nov 2008 - 20:46    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
tu as pas besoin de certain .kext, notamment ALCinject et IntelCPUPMdisabler, vu que tu as le disabler qui le comprends aussi, prends pas de pilotes vidéos, ça foire le truck souvent !
_________________________________________________
Dell 1720 C2D T7250 2go 320Go 8600M GT
iPhone 3G blanc 16Go Jailbreaké
Mighty Mouse bluetooth
configuration : 100% working avec véritable mac os x installé
avec sorties vidéos fonctionnelles Wink
un petit click s'il vous plaît Smile
ma brute
Je ne réponds plus aux demandes d'aide par MP
Revenir en haut
Francis


Hors ligne

Inscrit le: 16 Nov 2008
Messages: 14

MessagePosté le: Mar 25 Nov 2008 - 22:36    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
tete1995 a écrit:

tu as pas besoin de certain .kext, notamment ALCinject et IntelCPUPMdisabler, vu que tu as le disabler qui le comprends aussi, prends pas de pilotes vidéos, ça foire le truck souvent !
Bonsoir, et merci de s'intéresser à mon triste sort.

J'ai essayé avec uniquement

AppleACPIPlatform.kext
AppleAHCIPort.kext
AppleHDA.kext
ApplePS2Controller.kext
AppleSMBIOS.kext
Disabler.kext
IOAHCIFamily.kext
IOATAFamily.kext
IONetworkingFamily.kext
SMBIOSEnabler.kext
dsmos.kext

Et même plantage juste après avoir affiché le fond étoilé, avec le "spinning beachball", avec juste avant le message
display: family specific matching failed.

Comme j'utilise un clavier PS2 avec une souris USB, j'ai aussi changé
ApplePS2Controller.kext et AppleACPIPlatform.kext par ceux de Chun-Nan (le fameux PS2 Fix).

J'ai toujours un message
Extension com.apple.driver.AppleACPIPlatform has immediate dependencies on both com.apple.kernel and com.apple.kpi components; use only one
qui apparaît deux ou trois fois au cours du boot... et également des messages d'erreur réseau au sujet du DNSExplorer ou un truc du genre.
Par contre l'interface réseau a l'air de s'initialiser, puisque il annonce bien l'autodétection en 100M.

Même résultat.
Enfin, même absence de résultat. Neutral

J'ai également testé avec un véritable original du DVD, en pure peau de commercial de chez Apple, idem.

Pour info, il s'agit d'un DVD 10.5, première version d'octobre 2007, si ça peut avoir une importance ?

J'envisage le rhum, le sang de poulet et les poils de bouc recueillis à la pleine lune. Smile

Ce qui est un poil rageant, c'est que la Kaliway 10.5.1 et la 10.5.2 fonctionnent sur la même config et les mêmes réglages, avec un kernel vanilla au moins pour la 10.5.2 (je ne me souviens plus pour la 10.5.1).

Donc il n'y a pas de raison que ça ne fonctionne pas, c'est juste un truc qui doit méchapper.
_________________________________________________
--
Francis
Revenir en haut
tete1995
Modérateur

Hors ligne

Inscrit le: 05 Mar 2008
Messages: 2 413
Localisation: Soissons
Masculin

MessagePosté le: Mar 25 Nov 2008 - 22:41    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
alors essaye avec un CD generic.iso au lieu d'un truck configuré toi même, tu pourras le faire plus tard
_________________________________________________
Dell 1720 C2D T7250 2go 320Go 8600M GT
iPhone 3G blanc 16Go Jailbreaké
Mighty Mouse bluetooth
configuration : 100% working avec véritable mac os x installé
avec sorties vidéos fonctionnelles Wink
un petit click s'il vous plaît Smile
ma brute
Je ne réponds plus aux demandes d'aide par MP
Revenir en haut
Francis


Hors ligne

Inscrit le: 16 Nov 2008
Messages: 14

MessagePosté le: Mer 26 Nov 2008 - 06:03    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
tete1995 a écrit:

alors essaye avec un CD generic.iso au lieu d'un truck configuré toi même, tu pourras le faire plus tard

En fait j'avais commencé par ça au départ mais comme ça ne fonctionnait pas sur ma config (pas de support de l'AHCI, pas de réseau) j'avais alors commencé à essayer de modifier avec d'autres kext.

En fait, je me pose une question : quand j'ai installé la Kaliway 10.5.1 j'avais aussi quelques soucis de réseau et de son, résolus avec la Kaliway 10.5.2.
Là, j'essaie d'installer à partir de l'original de 10.5 tout court (octobre 2007).

Se peut-il que ça soit trop ancien pour supporter ma config, et qu'il faille un 10.5.2 ou plus récent, qui a servi de base aux Kalyways que j'ai essayé ?

Bon, je vais essayer de me faire prêter plus récent, pour en avoir le coeur net.
_________________________________________________
--
Francis
Revenir en haut
tete1995
Modérateur

Hors ligne

Inscrit le: 05 Mar 2008
Messages: 2 413
Localisation: Soissons
Masculin

MessagePosté le: Mer 26 Nov 2008 - 12:49    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
mais tout n'est pas obligatoirement à gérer dès le boot, je comprends pas, tu peux simplement faire marchere le generic.iso, si tu bootes dessus et que tu bootes sur OS X installé après, pas de problème, tu modifieras après !
_________________________________________________
Dell 1720 C2D T7250 2go 320Go 8600M GT
iPhone 3G blanc 16Go Jailbreaké
Mighty Mouse bluetooth
configuration : 100% working avec véritable mac os x installé
avec sorties vidéos fonctionnelles Wink
un petit click s'il vous plaît Smile
ma brute
Je ne réponds plus aux demandes d'aide par MP
Revenir en haut
Francis


Hors ligne

Inscrit le: 16 Nov 2008
Messages: 14

MessagePosté le: Mer 26 Nov 2008 - 13:12    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
tete1995 a écrit:
mais tout n'est pas obligatoirement à gérer dès le boot, je comprends pas, tu peux simplement faire marchere le generic.iso, si tu bootes dessus et que tu bootes sur OS X installé après, pas de problème, tu modifieras après !
Ben quand j'ai fait les essais à partir du generic.iso, même en repassant en SATA compatible IDE (non AHCI), en désactivant l'ACPI ou en essayant support mode S1 seul au lieu de S1&S3 : ça plantait toujours à l'install, au "mieux" à cet endroit (passage au fond d'écran) ou avant. J'ai essayé plusieurs versions d'iso récupérés censés fonctionner, mais peau'd balle. et ce en essayant pas mal de réglages de bios, HPET actif on non, XD bit enable ou pas, USB legacy mode ou pas, etc.
Rien, nib, nada, pas moyen, même sur le DVD d'origine, donc pas de problème de copie sur DVD+R DL.C'est seulement après cette série d'échecs (un super week-end Confused ) que j'ai commencé à essayer de customiser la liste des kext en me disant (c'était peut-être une connerie, mais c'était un peu en désespoir de cause) que plus le matos serait reconnu, mieux ce serait...

En gros, pas moyen de booter sur un iso pour installer le DVD retail, alors que je tourne quotidiennement avec le kernel vanilla sur la Kaliway 10.5.2.

Mais je ne m'avoue pas vaincu, ce serait trop simple : j'essaie dès ce soir avec une 10.5.4 originale en partant du generic iso et en désactivant AHCI, ACPI et tout ce qui peut diverger d'une config matérielle vraiment basique. J'vais même essayer avec la vidéo (P965) intégrée si ça veut pas rire, et en déposant la Geforce 8500.

Je l'aurai un jour... je l'aurai. Smile

Je vais pas me laisser pourrir par une bécane, non mais ! Smile
_________________________________________________
--
Francis
Revenir en haut
tete1995
Modérateur

Hors ligne

Inscrit le: 05 Mar 2008
Messages: 2 413
Localisation: Soissons
Masculin

MessagePosté le: Mer 26 Nov 2008 - 15:03    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
désactiver l'AHCI n'est pas une bonne idée, ni l'ACPI
_________________________________________________
Dell 1720 C2D T7250 2go 320Go 8600M GT
iPhone 3G blanc 16Go Jailbreaké
Mighty Mouse bluetooth
configuration : 100% working avec véritable mac os x installé
avec sorties vidéos fonctionnelles Wink
un petit click s'il vous plaît Smile
ma brute
Je ne réponds plus aux demandes d'aide par MP
Revenir en haut
Francis


Hors ligne

Inscrit le: 16 Nov 2008
Messages: 14

MessagePosté le: Mer 26 Nov 2008 - 15:11    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
tete1995 a écrit:
désactiver l'AHCI n'est pas une bonne idée, ni l'ACPI

Ca ne me plait pas non plus, mais pas moyen de booter sur un iso avec l'AHCI enabled (il ne reconnait plus le lecteur/graveur sata).
En les conservant activés (ce qui est ma config habituelle que ce soit sous linux ou Kaliway) ça ne fonctionne qu'en ajoutant les kext adaptés, mais ça refuse d'aller plus loin dans l'install que l'affichage du fond d'écran.

Bref, je vais reprendre ça du début posément, en partant du generic.iso et d'un original 10.5.4, et en en modifiant qu'un paramètre à la fois.

Il n'y a pas de raison que ça ne finisse pas par fonctionner avec un Core2duo (SSE3 donc) et qui supporte le noyau mach_kernel "vanilla" 9.2.0 installé par la Kaliway.

Stay tuned! Smile
_________________________________________________
--
Francis
Revenir en haut
Francis


Hors ligne

Inscrit le: 16 Nov 2008
Messages: 14

MessagePosté le: Mer 26 Nov 2008 - 20:53    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
Francis a écrit:

tete1995 a écrit:
désactiver l'AHCI n'est pas une bonne idée, ni l'ACPI


Ca ne me plait pas non plus, mais pas moyen de booter sur un iso avec l'AHCI enabled (il ne reconnait plus le lecteur/graveur sata).
En les conservant activés (ce qui est ma config habituelle que ce soit sous linux ou Kaliway) ça ne fonctionne qu'en ajoutant les kext adaptés, mais ça refuse d'aller plus loin dans l'install que l'affichage du fond d'écran.

Bref, je vais reprendre ça du début posément, en partant du generic.iso et d'un original 10.5.4, et en en modifiant qu'un paramètre à la fois.

Il n'y a pas de raison que ça ne finisse pas par fonctionner avec un Core2duo (SSE3 donc) et qui supporte le noyau mach_kernel "vanilla" 9.2.0 installé par la Kaliway.

Stay tuned! Smile


Bon, des news :
En reprenant un iso fait il y a deux jours et qui plantait au fond d'écran, c'est passé avec une galette 10.5.4, et j'ai pu finir l'install...

Seul problème : au reboot je n'avais plus de clavier et il s'arrête sur la page demandant de connecter un clavier.

J'ai un clavier Cherry PS2 et une souris USB, mais c'est censé fonctionner.

Enfin, c'est pas grave, le plus dur est fait, il ne me reste plus qu'à affiner les kext à mettre dans l'iso, je sais que ça va fonctionner.

Je ne changerai le tire en RESOLU que quand j'aurais fini l'install. Smile
_________________________________________________
--
Francis
Revenir en haut
Raid13
Administrateur

Hors ligne

Inscrit le: 15 Oct 2007
Messages: 3 932
Localisation: Orléans
Masculin

MessagePosté le: Mer 26 Nov 2008 - 22:06    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
et avec un clavier usb ?
_________________________________________________
HackIntosh Mac Pro
Intel Core 2 Duo E8400
Gigabyte EP35-DS3(Sleep/Reboot/Shutdown)
2 Go DDR2 - 800 OK
500Go Samsung F1 Sata2
Pioneer DVR-212D
GeForce 7800GTX 256MoOK
Boitier PowerMac G5 ATX by Alex
Mac OS X.5.5 iDeneb v1.1 OK

http://raid13.labrute.fr

Power Mac G4 Gigabit Ethernet Bi-Pro 450 @ Gigadesign mono G4/1,8GHz

<a href="http://mac-on-pc.fr" target="_blank"><img src="http://maconpc.niloo.fr/images/pub88x31.gif" alt="Gamejapanime" border="0"></a>

Je ne réponds plus aux MPs de demande d'aide // CF. Charte
Revenir en haut
Visiter le site web du posteur
Francis


Hors ligne

Inscrit le: 16 Nov 2008
Messages: 14

MessagePosté le: Jeu 27 Nov 2008 - 05:31    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132 Répondre en citant
Raid13 a écrit:

et avec un clavier usb ?

Je n'en ai pas... pour l'instant. Faut que je commande un Macally chez MacWay, à moins que pour Noël je m'offre un alu de chez Apple. Surprised)

Bref, avec un iso légèrement modifié j'ai pu rebooter avec le clavier PS2 et la souris USB, finir l'install (je suis actuellement sous 10.5.4 noyau vanilla 9.4.0).
Il ne me reste plus qu'à corriger la gestion de la carte graphique (il voit bien une nvdia mais pas la totalité de la mémoire vidéo, et Quartz n'est pas géré) et du chipset audio, mais avant je vais faire l'upgrade 10.5.5 à partir du fichier téléchargé depuis chez Apple.
Quelques bricoles, le plus dur est fait.

Je posterai le contenu de l'iso définitif qui rendra l'install fonctionnelle à 100%, et que ça démarrera directement depuis la partition EFI, sans disque dur ou clé USB.

Content je suis. Smile
_________________________________________________
--
Francis
Revenir en haut
Contenu Sponsorisé






MessagePosté le: Aujourd’hui à 18:56    Sujet du message: [Résolu] Echec à l'install de Leopard 10.5 retail / Boot-132
Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Installer OS X sur PC Index du Forum :: Avant et Après l'installation :: Problèmes d'installation sur PC Intel Toutes les heures sont au format GMT + 1 Heure
Aller à la page: 1, 2  >
Page 1 sur 2

 
Sauter vers:  

Portail | Index | créer forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation


Powered by phpBB © 2001, 2015 phpBB Group Traduction par : phpBB-fr.com 
Macinscott theme by Scott Stubblefield